46 lines
1.1 KiB
Nix
46 lines
1.1 KiB
Nix
{
|
|
description = "Objective-C runtime bindings for Zig";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/release-24.05";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
zig.url = "github:mitchellh/zig-overlay";
|
|
|
|
# Used for shell.nix
|
|
flake-compat = {
|
|
url = github:edolstra/flake-compat;
|
|
flake = false;
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
flake-utils,
|
|
...
|
|
} @ inputs: let
|
|
overlays = [
|
|
# Other overlays
|
|
(final: prev: {
|
|
zigpkgs = inputs.zig.packages.${prev.system};
|
|
})
|
|
];
|
|
|
|
# Our supported systems are the same supported systems as the Zig binaries
|
|
systems = builtins.attrNames inputs.zig.packages;
|
|
in
|
|
flake-utils.lib.eachSystem systems (
|
|
system: let
|
|
pkgs = import nixpkgs {inherit overlays system;};
|
|
in rec {
|
|
devShells.default = pkgs.mkShell {
|
|
nativeBuildInputs = with pkgs; [
|
|
zigpkgs."0.13.0"
|
|
];
|
|
};
|
|
|
|
# For compatibility with older versions of the `nix` binary
|
|
devShell = self.devShells.${system}.default;
|
|
}
|
|
);
|
|
}
|